Crashlytics pour ndk ne peut pas accéder à la décompression du système

kathy zhou 07/26/2017. 1 answers, 97 views
android-ndk android-ndk native crashlytics google-fabric

Crashlytics pour ndk ne peut pas accéder à la décompression du système avec les informations d'erreur: Impossible de trouver les bibliothèques de déroulage utilisables sur le périphérique, retombant à un simple déroulement

Peut-être que cet échec a causé que nous avons seulement une ligne pour le crash natif.

Mon appareil est le Nexus 6 avec la plate-forme 7.1.1

1 Answers


Mike Bonnell 07/26/2017.

Mike de Fabric ici. Oui, si nous ne pouvons pas trouver libcorkscrew et libunwind, nous passons à notre propre décompteur simple. Le dérouleur simple est seulement capable d'obtenir l'image la plus haute dans un crash, c'est pourquoi vous voyez ce comportement. Nous prévoyons de faire cela mieux.

4 comments
1 kathy zhou 07/27/2017
Merci pour votre réponse rapide. Ma question supplémentaire est la suivante: y a-t-il une solution pour cela? Pourrions-nous ajouter libunwind à notre projet pour résoudre ce problème?
Mike Bonnell 07/28/2017
Pas pour le moment, malheureusement, mais comme je l'ai mentionné, nous travaillons à l'améliorer.
Maris B. 08/23/2017
@ MikeBonnell - tout ETA sur "faire ce mieux" ?. Un mois plus tard et toujours "Impossible de trouver des bibliothèques de déroulage utilisables sur l'appareil, retombant à un simple déroulement" sur Android 5.0 et Android 7.0
Mike Bonnell 08/23/2017
Je n'ai pas d'ETA que je puisse partager publiquement. Si vous souhaitez tester tout ce sur quoi nous travaillons, envoyez un courrier électronique à support (at) fabric (dot) io avec une référence à ce sujet.

Related questions

Hot questions

Language

Popular Tags